OutlookUservoice_icon_outlook Outlook Feedback by UserVoice

How can we improve Outlook on the web?

The system is extremely slow. When I open new emails I receive an error message. The system stops, reloads and returns. It's frustrating.

4,176 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

First off, thank you ALL for providing such detailed feedback around some of the performance issues you had faced. Over the last few weeks we have been shipping out a variety of fixes that will address some of the issues that were reported.

The items that we fixed were largely around some specific browser and Operating System combinations.

If you are hitting any other performance issues, please open up a new feedback or ticket and we will debug those as well.

Thanks!

David Los

1507 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    when open old email, it will loading for arund 2 -5 sec. **** slower than the old version

  • Melissa Koehl commented  ·   ·  Flag as inappropriate

    every click to view an email, scroll, and type is followed by a 5-10 sec delay. Emails are not sent after clicking "send" and instead just saved as draft. By far the worst email program I've ever used. It took 30 min to send 2 very brief emails. I've never experienced an email program this terrible.

  • Erick commented  ·   ·  Flag as inappropriate

    Not very user friendly, the palet color it's not the best, it's better to stick to one color or use a more contrastfull color, if that's a word.
    Difficult to know what are you looking and searching

  • eLIZABETH commented  ·   ·  Flag as inappropriate

    tHIS IS WAY SLOWER THEN OUR ORIGINAL OUTLOOK. dID NOT LIKE TRYING THE NEW LOOK IT IS SUPER SLOW. IT WAS FASTER WITH THE ORIGINAL ONE.

  • levente.lenart commented  ·   ·  Flag as inappropriate

    Search is slow like an old Windows 97! I typed like "rexroth" and just nothing risen. If I search in a folder for number it appear after a minute (60-65 sec!!!)

  • Simran commented  ·   ·  Flag as inappropriate

    It's too complicated to use. UI should be user-friendly and moreover, the look is not appealing.

  • Michael Daw commented  ·   ·  Flag as inappropriate

    Not sure how long it's been happening (a few days or so). When I open the page and click on a message in my inbox, it take a very long time to load it. I only see the loading spinner in the right pane. Usually between 30 seconds and a minute.
    Additionally, the first time I attempt to send a message takes a similar length of time.
    After the first send or receive, things seem to go back to normal.

  • Tom_Reidy commented  ·   ·  Flag as inappropriate

    It is much slower and the in box must be manually updated.
    You have to take an action n like change the filter to see new emails.

    Speed is really bad.

← Previous 1 3 4 5 75 76

Feedback and Knowledge Base