OutlookUservoice_icon_outlook Outlook Feedback by UserVoice

Outlook for Android

don't take contacts from my phone contacts.

At least give me the OPTION of importing my contacts. Plus, I need to be able to delete them. Microsoft... enough said.

4 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Hansen, Jacob M. shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Completed  ·  AdminMicrosoft Support (Admin, Outlook.com) responded  · 

Hi there,

Thank you for using Outlook and letting us know about your current experience. We really appreciate your support.

We are so sorry this is happening to you. Please contact us through the Help Section of the app (in the Settings) so that we can assist you in the best possible way.

We look forward to fixing this for you.

All the best
The Outlook Mobile Team

PS: We are not able to see replies on this address. Please use the Help Section of the app for any questions.

1 comment

Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Sami Jumppanen commented  ·   ·  Flag as inappropriate

    Hi, this is a real issue. Phone and SIM contacts should never be imported without informing the user! There are two things that need to be corrected:
    1) telling about this feature upon Outlook startup and
    2) let the user opt out of the import.

    At work we found out the feature the hard way: a fireman missed a call at night, because Outlook had taken SIM contacts with assigned ring tones. His presence was needed, but he did not wake up to silent call. This is an extreme case, but helps to understand the importance of contacts.

    This automatic import still exists in the latest Outlook version, we got a new case today. An employee told she cannot find her phone contacts any more. Turns out they are imported to the Outlook email account, but as the contact sync option is not enabled by default, they are not showing up in Android contacts.

Outlook for Android: People

Feedback and Knowledge Base